Forum

MT4 PROBLEME ASSIST...
 
Notifications
Retirer tout

MT4 PROBLEME ASSISTANT

Steph
(@steph)
Reputable Member
Inscription: Il y a 12 ans
Posts: 299
Début du sujet  

Salut à tous,

A la base, j'ai ouvert un compte démo depuis le site de MetaQuote. On peut y télé charger MetaTrader 4 gratuitement. Le compte démo est ouvert chez Alpari UK et est illimité. Jusqu'ice, pas de problème. j'ai eu accès aux historiques et j'ai pu, par exemple, charger l'historique de l'EurUsd en M1 (bougie d'une minute) depuis 1971 je crois.

Les choses se sont gâtées lorsque j'ai commencé à programmer dans la perspective de créer un EA. L'assitant ne présente pas dans son menu l'option "Include" ni l'option "Library", alors qu'il y a bien les template dans de dossier éponyme...

Mon compte démo a fonctionné durant près de 2 mois sans aucun problèmes, mais pour tenter de remédier à ces manques, j'ai dés-installé le logiciel, puis j'ai recommencé plusieurs fois l'installation toujours sans obtenir les options manquantes. Comme d'autres n'ont semble-t-il aucune difficulté pour avoir une version "complète", je suppose que j'ai fait une erreur quelque part, mais où ?

Si donc parmi vous il se trouve quelqu'un qui puisse voler à mon secours, alors je jure de prier de toute mes forces le Dieu des bougies afin qu'il fasse sa fortune, et pourquoi pas la mienne... On ne sait jamais, si ce Dieu m'écoutait !

Bon, en attendant la richesse à venir, voici l'image de l'assistant défaillant :[attachment=0:20381psa]ce Assistant MT4.jpg[/attachment:20381psa]


   
Citation
Jeff
 Jeff
(@jeff)
New Member
Inscription: Il y a 10 ans
Posts: 2
 

Bonjour,

L'assistant ne sert à peu près à rien sauf peut être taper à ta place start(), deinit(), etc...

Comme il y a des milliers de sources sur le net (tant que tu n'en as pas des 100aines perso sur ton disque) tu pars d'un vieux source pour en commencer un nouveau.

Ce qui est beaucoup plus efficace pour piocher des blocs de code qui reviennent tout le temps, d'avoir en bas de source un vieux tas de lignes en commentaire.

Jeff


   
RépondreCitation
Steph
(@steph)
Reputable Member
Inscription: Il y a 12 ans
Posts: 299
Début du sujet  

Salut Jeff,

Merci de ta réponse. La-Vague avait trouvé la solution et me l'avait communiquée (c'est juste un problème de traduction des options de l'assistant) et j'ai négligé de la raporter ici... désolé !

A l'attention de ceux qui rencontreraient le même problème, il suffit de sélectionner "Générer suivant modèle" pour obtenir l'option "Library" et de sélectionner "Pour continuer cliquer sur suivant" pour obtenir l'option "Include"...

@+


   
RépondreCitation
Share: